Как за 1 минуту выбрать самые длинные ключевые слова в 300 группах объявлений

Исходные данные.

1 000 ключевых слов, 200-300 групп объявлений, 2-3 рекламные кампании.

Начинаем писать тексты. Одна из задач, выбрать в каждой группе объявлений (далее ГО) самое длинное ключевое слово (далее КС), чтобы именно его использовать в ДВКС.
Перебирать руками долго и можно допустить ошибку.
Метод, описанный ниже, помогает в несколько кликов:

 — сделать выборку самого длинного КС;
 — соотнести его с ГО и РК;
 — скопировать полученное на лист “Объявления” и просто начать их писать.

Рассказываю пошагово на ограниченной семантике.

Исходная семантика. Цветом подсвечено то, что должно получиться на выходе в таблице.

Работаем на листе КС. Если боитесь что-то испортить, можно сделать копию листа.
Слева добавляем 2 столбца: Длина КС и Сцепка ГО+Длина КС.
В столбце Длина КС вычисляем длину каждого ключевого слова по формуле =ДЛСТР(F3). F3 — это ячейка с ключевым словом в соответствующей строке.

 

В столбце Сцепка ГО+Длина КС соединяем соответствующие ячейки, без пробелов, по формуле =СЦЕПИТЬ(E3;B3)

 

Протягиваем формулы на всю таблицу. На выходе имеем столбец С с уникальными названиями, по которым и будем искать наше самое длинное слово.

 

Далее выделяем всю получившуюся таблицу и на вкладке “Вставка” жмем “Сводная таблица”.

По умолчанию должно выбрать Ваш диапазон. В моем случае это Лист КС, Столбцы B-F, Строки 2-36.

Вставляем на новый лист.

На созданном листе мы выбираем Ad Group и Длина КС. Именно в таком порядке.

Меняем параметр поля значений с Суммы на Максимум по полю “Длина КС”.

Снова делаем сцепку столбцов Ad Group и Длина КС, но уже в сводной таблице.

Формула =СЦЕПИТЬ(A4;B4) и протягиваем.

Финал. Используя функцию ВПР ищем соответствующие название РК, ГО и КС.

Эта функция ищет заданное значение (в моем примере это значения столбца сцепки) в крайнем левом столбце указанной таблицы (то, что выделили на листе КС, рис. 5) двигаясь сверху-вниз и, найдя его, выдает содержимое соответствующих ячеек справа (РК, ГО, КС).

Чтобы корректно протянуть формулы искомое значение фиксируем по столбцу. Область таблицы фиксируем и по столбцу, и по строке.

Готовые формулы:

Для столбца E, ищем название РК: =ВПР($D4;КС!$C:$F;2;0)

Для столбца F, ищем название ГО: =ВПР($D4;КС!$C:$F;3;0)

Для столбца G, выбираем КС: =ВПР($D4;КС!$C:$F;4;0)

Итог

Если в ГО есть 2 и более КС с одинаковым количеством символов, то будет выбрано первое при поиске сверху вниз.

Может показаться, что все сложно. Но если разберетесь и запомните алгоритм, то получится значительно сократить время на обработку. У меня данная выборка занимает не больше минуты.

Год выпуска: 2020, одна из лучших.
Оставьте комментарий
ХОТИТЕ ПОЛУЧАТЬ ПОЛЕЗНУЮ РАССЫЛКУ?

Раз в месяц я делаю рассылку, включающую актуальные новости по Google Ads, Яндекс.Директ и веб-аналитике. Если вы хотите быть в курсе последних событий и успевать за нововведениями, оставьте, пожалуйста, свой электронный адрес в форме.



Отправляя форму, вы соглашаетесь с политикой конфиденциальности